CVE-2018-16476

NameCVE-2018-16476
DescriptionA Broken Access Control vulnerability in Active Job versions >= 4.2.0 allows an attacker to craft user input which can cause Active Job to deserialize it using GlobalId and give them access to information that they should not have. This vulnerability has been fixed in versions 4.2.11, 5.0.7.1, 5.1.6.1, and 5.2.1.1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs914847

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rails (PTS)stretch2:4.2.7.1-1+deb9u2fixed
stretch (security)2:4.2.7.1-1+deb9u5fixed
buster, buster (security)2:5.2.2.1+dfsg-1+deb10u3fixed
bookworm, sid, bullseye2:6.0.3.7+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
railssourcejessie(not affected)
railssourcestretch2:4.2.7.1-1+deb9u1
railssource(unstable)2:5.2.2+dfsg-1914847

Notes

[jessie] - rails <not-affected> (only affects >= 4.2.0)
https://www.openwall.com/lists/oss-security/2018/11/27/4

Search for package or bug name: Reporting problems