CVE-2018-16487

NameCVE-2018-16487
DescriptionA prototype pollution vulnerability was found in lodash <4.17.11 where the functions merge, mergeWith, and defaultsDeep can be tricked into adding or modifying properties of Object.prototype.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-lodash (PTS)jessie2.4.1+dfsg-3vulnerable
stretch4.16.6+dfsg-2vulnerable
buster, sid4.17.11+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-lodashsource(unstable)4.17.11+dfsg-1unimportant

Notes

https://hackerone.com/reports/380873
nodejs not covered by security support

Search for package or bug name: Reporting problems