CVE-2018-16742

NameCVE-2018-16742
DescriptionAn issue was discovered in mgetty before 1.2.1. In contrib/scrts.c, a stack-based buffer overflow can be triggered via a command-line parameter.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mgetty (PTS)jessie1.1.36-2.1vulnerable
jessie (security)1.1.36-2.1+deb8u1vulnerable
stretch (security), stretch1.1.36-3+deb9u1vulnerable
buster, sid1.2.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mgettysource(unstable)1.2.1-1unimportant

Notes

contrib/scrts not built in Debian packaging
https://www.x41-dsec.de/lab/advisories/x41-2018-007-mgetty/
Upstream removed contrib/scrts in 7d018d471f4c737f77ef281f5859a3b1c9ded42f (1.2.1)

Search for package or bug name: Reporting problems