CVE-2018-16839

NameCVE-2018-16839
DescriptionCurl versions 7.33.0 through 7.61.1 are vulnerable to a buffer overrun in the SASL authentication code that may lead to denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1568-1, DSA-4331-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
curl (PTS)jessie7.38.0-4+deb8u11vulnerable
jessie (security)7.38.0-4+deb8u13fixed
stretch (security), stretch7.52.1-5+deb9u8fixed
buster, sid7.62.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
curlsource(unstable)7.62.0-1high
curlsourcejessie7.38.0-4+deb8u13highDLA-1568-1
curlsourcestretch7.52.1-5+deb9u8highDSA-4331-1

Notes

https://curl.haxx.se/docs/CVE-2018-16839.html
Fixed by: https://github.com/curl/curl/commit/f3a24d7916b9173c69a3e0ee790102993833d6c5

Search for package or bug name: Reporting problems