CVE-2018-16841

NameCVE-2018-16841
DescriptionSamba from version 4.3.0 and before versions 4.7.12, 4.8.7 and 4.9.3 are vulnerable to a denial of service. When configured to accept smart-card authentication, Samba's KDC will call talloc_free() twice on the same memory if the principal in a validly signed certificate does not match the principal in the AS-REQ. This is only possible after authentication with a trusted certificate. talloc is robust against further corruption from a double-free with talloc_free() and directly calls abort(), terminating the KDC process.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4345-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
samba (PTS)jessie2:4.2.14+dfsg-0+deb8u9fixed
jessie (security)2:4.2.14+dfsg-0+deb8u10fixed
stretch2:4.5.12+dfsg-2+deb9u3vulnerable
stretch (security)2:4.5.12+dfsg-2+deb9u4fixed
buster, sid2:4.9.2+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sambasource(unstable)2:4.9.2+dfsg-2
sambasourcejessie(not affected)
sambasourcestretch2:4.5.12+dfsg-2+deb9u4DSA-4345-1

Notes

[jessie] - samba <not-affected> (Vulnerable code not present)
https://www.samba.org/samba/security/CVE-2018-16841.html

Search for package or bug name: Reporting problems