CVE-2018-16842

NameCVE-2018-16842
DescriptionCurl versions 7.14.1 through 7.61.1 are vulnerable to a heap-based buffer over-read in the tool_msgs.c:voutf() function that may result in information exposure and denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1568-1, DSA-4331-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
curl (PTS)jessie7.38.0-4+deb8u11vulnerable
jessie (security)7.38.0-4+deb8u13fixed
stretch (security), stretch7.52.1-5+deb9u8fixed
buster, sid7.62.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
curlsource(unstable)7.62.0-1medium
curlsourcejessie7.38.0-4+deb8u13mediumDLA-1568-1
curlsourcestretch7.52.1-5+deb9u8mediumDSA-4331-1

Notes

https://curl.haxx.se/docs/CVE-2018-16842.html
Fixed by: https://github.com/curl/curl/commit/d530e92f59ae9bb2d47066c3c460b25d2ffeb211

Search for package or bug name: Reporting problems