CVE-2018-16846

NameCVE-2018-16846
DescriptionIt was found in Ceph versions before 13.2.4 that authenticated ceph RGW users can cause a denial of service against OMAPs holding bucket indices.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1696-1
NVD severitymedium (attack range: remote)
Debian Bugs921947

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ceph (PTS)jessie0.80.7-2+deb8u2vulnerable
jessie (security)0.80.7-2+deb8u3fixed
stretch (security), stretch10.2.11-2vulnerable
buster, sid12.2.11+dfsg1-2.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cephsource(unstable)12.2.11+dfsg1-1medium921947
cephsourcejessie0.80.7-2+deb8u3mediumDLA-1696-1

Notes

http://tracker.ceph.com/issues/35994
https://github.com/ceph/ceph/commit/4337e6a7d9f92c8549ebee20d0dd67a01e49857f
https://github.com/ceph/ceph/commit/ab29bed2fc9f961fe895de1086a8208e21ddaddc
Backport to 12.2.11: https://tracker.ceph.com/issues/37831

Search for package or bug name: Reporting problems