CVE-2018-16847

NameCVE-2018-16847
DescriptionAn OOB heap buffer r/w access issue was found in the NVM Express Controller emulation in QEMU. It could occur in nvme_cmb_ops routines in nvme device. A guest user/process could use this flaw to crash the QEMU process resulting in DoS or potentially run arbitrary code with privileges of the QEMU process.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs912655

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)jessie1:2.1+dfsg-12+deb8u6fixed
jessie (security)1:2.1+dfsg-12+deb8u8fixed
stretch1:2.8+dfsg-6+deb9u4fixed
stretch (security)1:2.8+dfsg-6+deb9u5fixed
buster1:2.12+dfsg-3vulnerable
sid1:3.1+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusource(unstable)1:3.1+dfsg-1912655
qemusourcejessie(not affected)
qemusourcestretch(not affected)
qemu-kvmsource(unstable)(not affected)

Notes

[stretch] - qemu <not-affected> (support for Controller Memory Buffers added later)
[jessie] - qemu <not-affected> (support for Controller Memory Buffers added later)
- qemu-kvm <not-affected> (support for Controller Memory Buffers added later)
https://lists.gnu.org/archive/html/qemu-devel/2018-11/msg00200.html
https://git.qemu.org/?p=qemu.git;a=commit;h=87ad860c622cc8f8916b5232bd8728c08f938fce

Search for package or bug name: Reporting problems