CVE-2018-16851

NameCVE-2018-16851
DescriptionSamba from version 4.0.0 and before versions 4.7.12, 4.8.7, 4.9.3 is vulnerable to a denial of service. During the processing of an LDAP search before Samba's AD DC returns the LDAP entries to the client, the entries are cached in a single memory object with a maximum size of 256MB. When this size is reached, the Samba process providing the LDAP service will follow the NULL pointer, terminating the process. There is no further vulnerability associated with this issue, merely a denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4345-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
samba (PTS)jessie2:4.2.14+dfsg-0+deb8u9vulnerable
jessie (security)2:4.2.14+dfsg-0+deb8u10vulnerable
stretch2:4.5.12+dfsg-2+deb9u3vulnerable
stretch (security)2:4.5.12+dfsg-2+deb9u4fixed
buster, sid2:4.9.2+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sambasource(unstable)2:4.9.2+dfsg-2
sambasourcestretch2:4.5.12+dfsg-2+deb9u4DSA-4345-1

Notes

https://www.samba.org/samba/security/CVE-2018-16851.html

Search for package or bug name: Reporting problems