CVE-2018-16859

NameCVE-2018-16859
DescriptionExecution of Ansible playbooks on Windows platforms with PowerShell ScriptBlock logging and Module logging enabled can allow for 'become' passwords to appear in EventLogs in plaintext. A local user with administrator privileges on the machine can view these logs and discover the plaintext password. Ansible Engine 2.8 and older are believed to be vulnerable.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ansible (PTS)stretch2.2.1.0-2+deb9u1fixed
stretch (security)2.2.1.0-2+deb9u2fixed
buster2.7.7+dfsg-1fixed
buster (security)2.7.7+dfsg-1+deb10u1fixed
bookworm, bullseye, sid2.10.7+merged+base+2.10.8+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ansiblesource(unstable)(not affected)

Notes

- ansible <not-affected> (Only issue when executing Ansible playbooks on Windows platforms)

Search for package or bug name: Reporting problems