CVE-2018-16866

NameCVE-2018-16866
DescriptionAn out of bounds read was discovered in systemd-journald in the way it parses log messages that terminate with a colon ':'. A local attacker can use this flaw to disclose process memory data. Versions from v221 to v239 are vulnerable.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4367-1
NVD severitylow (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
systemd (PTS)jessie215-17+deb8u7fixed
jessie (security)215-17+deb8u13fixed
stretch232-25+deb9u12fixed
stretch (security)232-25+deb9u11fixed
buster241-7~deb10u1fixed
bullseye, sid242-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
systemdsource(unstable)240-1low
systemdsourcejessie(not affected)
systemdsourcestretch232-25+deb9u7lowDSA-4367-1

Notes

[jessie] - systemd <not-affected> (Vulnerable code not present)
Introduced in: https://github.com/systemd/systemd/commit/ec5ff4445cca6a1d786b8da36cf6fe0acc0b94c8 (v221)
Fixed by: https://github.com/systemd/systemd/commit/a6aadf4ae0bae185dc4c414d492a4a781c80ffe5 (v240) [1/2]
Fixed by: https://github.com/systemd/systemd/commit/8595102d3ddde6d25c282f965573a6de34ab4421 (v240) [2/2]
https://www.openwall.com/lists/oss-security/2019/01/09/3
https://www.qualys.com/2019/01/09/system-down/system-down.txt

Search for package or bug name: Reporting problems