CVE-2018-16880

NameCVE-2018-16880
DescriptionA flaw was found in the Linux kernel's handle_rx() function in the [vhost_net] driver. A malicious virtual guest, under specific conditions, can trigger an out-of-bounds write in a kmalloc-8 slab on a virtual host which may lead to a kernel memory corruption and a system panic. Due to the nature of the flaw, privilege escalation cannot be fully ruled out. Versions from v4.16 and newer are vulnerable.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie3.16.56-1+deb8u1fixed
jessie (security)3.16.76-1fixed
stretch4.9.189-3fixed
stretch (security)4.9.189-3+deb9u2fixed
buster4.19.67-2+deb10u1fixed
buster (security)4.19.67-2+deb10u2fixed
bullseye5.2.17-1fixed
sid5.3.9-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)4.19.20-1
linuxsourcejessie(not affected)
linuxsourcestretch(not affected)

Notes

[stretch] - linux <not-affected> (Vulnerable code introduced in 4.16-rc1)
[jessie] - linux <not-affected> (Vulnerable code introduced in 4.16-rc1)
https://www.openwall.com/lists/oss-security/2019/01/25/1

Search for package or bug name: Reporting problems