CVE-2018-16881

NameCVE-2018-16881
DescriptionA denial of service vulnerability was found in rsyslog in the imptcp module. An attacker could send a specially crafted message to the imptcp socket, which would cause rsyslog to crash. Versions before 8.27.0 are vulnerable.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3016-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rsyslog (PTS)buster, buster (security)8.1901.0-1+deb10u2fixed
bullseye (security), bullseye8.2102.0-2+deb11u1fixed
bookworm, sid8.2208.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rsyslogsourcejessie(not affected)
rsyslogsourcestretch8.24.0-1+deb9u2DLA-3016-1
rsyslogsource(unstable)8.27.0-2

Notes

[jessie] - rsyslog <not-affected> (Vulnerable code introduced in 8.13.1)
Fixed by: https://github.com/rsyslog/rsyslog/commit/0381a0de64a5a048c3d48b79055bd9848d0c7fc2
Introduced by: https://github.com/rsyslog/rsyslog/commit/6c52f29d593a27f934a1871d40eed84ebde3f3a6
Fix introduces CVE-2022-24903

Search for package or bug name: Reporting problems