CVE-2018-17057

NameCVE-2018-17057
DescriptionAn issue was discovered in TCPDF before 6.2.22. Attackers can trigger deserialization of arbitrary data via the phar:// wrapper.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs908866

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tcpdf (PTS)jessie6.0.093+dfsg-1+deb8u1vulnerable
stretch6.2.12+dfsg2-1vulnerable
buster, sid6.2.13+dfsg-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tcpdfsource(unstable)(unfixed)high908866

Notes

[stretch] - tcpdf <no-dsa> (Minor issue)
[jessie] - tcpdf <ignored> (Minor issue)
https://github.com/tecnickcom/TCPDF/commit/1861e33fe05f653b67d070f7c106463e7a5c26e
Was considered minor for jessie since arbitrary deserialization
is still possible using http and https.

Search for package or bug name: Reporting problems