CVE-2018-17088

NameCVE-2018-17088
DescriptionThe ProcessGpsInfo function of the gpsinfo.c file of jhead 3.00 may allow a remote attacker to cause a denial-of-service attack or unspecified other impact via a malicious JPEG file, because there is an integer overflow during a check for whether a location exceeds the EXIF data length. This is analogous to the CVE-2016-3822 integer overflow in exif.c. This gpsinfo.c vulnerability is unrelated to the CVE-2018-16554 gpsinfo.c vulnerability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2054-1
NVD severitymedium
Debian Bugs907925

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jhead (PTS)stretch1:3.00-4+deb9u1fixed
buster1:3.00-8fixed
bullseye, sid1:3.04-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jheadsourcejessie1:2.97-1+deb8u2DLA-2054-1
jheadsourcestretch1:3.00-4+deb9u1
jheadsource(unstable)1:3.00-8907925

Search for package or bug name: Reporting problems