CVE-2018-17199

NameCVE-2018-17199
DescriptionIn Apache HTTP Server 2.4 release 2.4.37 and prior, mod_session checks the session expiry time before decoding the session. This causes session expiry time to be ignored for mod_session_cookie sessions since the expiry time is loaded when the session is decoded.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1647-1, DSA-4422-1
NVD severitymedium (attack range: remote)
Debian Bugs920303

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apache2 (PTS)jessie2.4.10-10+deb8u12vulnerable
jessie (security)2.4.10-10+deb8u14fixed
stretch (security), stretch2.4.25-3+deb9u7fixed
buster2.4.38-3fixed
bullseye, sid2.4.41-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apache2source(unstable)2.4.38-1low920303
apache2sourcejessie2.4.10-10+deb8u13mediumDLA-1647-1
apache2sourcestretch2.4.25-3+deb9u7mediumDSA-4422-1

Notes

https://www.openwall.com/lists/oss-security/2019/01/22/3
2.4.x http://svn.apache.org/r1851409
2.5.x http://svn.apache.org/r1850947

Search for package or bug name: Reporting problems