CVE-2018-17206

NameCVE-2018-17206
DescriptionAn issue was discovered in Open vSwitch (OvS) 2.7.x through 2.7.6. The decode_bundle function inside lib/ofp-actions.c is affected by a buffer over-read issue during BUNDLE action decoding.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openvswitch (PTS)jessie (security), jessie2.3.0+git20140819-3+deb8u1fixed
stretch2.6.2~pre+git20161223-3vulnerable
buster, sid2.10.0+2018.08.28+git.8ca7c82b7d+ds1-10vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openvswitchsource(unstable)(unfixed)
openvswitchsourcejessie(not affected)

Notes

[jessie] - openvswitch <not-affected> (Vulnerable code does not exist; no such function)
https://github.com/openvswitch/ovs/commit/5026a263d7846077eee540de42192d27da513226 (master)
https://github.com/openvswitch/ovs/commit/20626d38c1a1d4cebb5a6911ea3cb6a7f4f993f8 (branch-2.8)
https://github.com/openvswitch/ovs/commit/9237a63c47bd314b807cda0bd2216264e82edbe8 (branch-2.7)

Search for package or bug name: Reporting problems