CVE-2018-17294

NameCVE-2018-17294
DescriptionThe matchCurrentInput function inside lou_translateString.c of Liblouis prior to 3.7 does not check the input string's length, allowing attackers to cause a denial of service (application crash via out-of-bounds read) by crafting an input file with certain translation dictionaries.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
liblouis (PTS)jessie2.5.3-3+deb8u1vulnerable
stretch3.0.0-3+deb9u4vulnerable
buster3.8.0-2fixed
bullseye, sid3.12.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
liblouissource(unstable)3.7.0-1

Notes

[stretch] - liblouis <no-dsa> (Minor issue)
[jessie] - liblouis <ignored> (Minor issue)
https://github.com/liblouis/liblouis/commit/5e4089659bb49b3095fa541fa6387b4c40d7396e
https://github.com/liblouis/liblouis/issues/635

Search for package or bug name: Reporting problems