CVE-2018-17825

NameCVE-2018-17825
DescriptionAn issue was discovered in AdPlug 2.3.1. There are several double-free vulnerabilities in the CEmuopl class in emuopl.cpp because of a destructor's two OPLDestroy calls, each of which frees TL_TABLE, SIN_TABLE, AMS_TABLE, and VIB_TABLE.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1534-1
Debian Bugs910534

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
adplug (PTS)jessie2.2.1+dfsg3-0.1vulnerable
jessie (security)2.2.1+dfsg3-0.1+deb8u1fixed
buster, sid, stretch2.2.1+dfsg3-0.4vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
adplugsource(unstable)(unfixed)910534
adplugsourcejessie2.2.1+dfsg3-0.1+deb8u1DLA-1534-1

Notes

[stretch] - adplug <no-dsa> (Minor issue)
https://github.com/adplug/adplug/issues/67
https://github.com/adplug/adplug/commit/19ebb61bf92262dc1868de10ba5a211db249ce76

Search for package or bug name: Reporting problems