CVE-2018-17828

NameCVE-2018-17828
DescriptionDirectory traversal vulnerability in ZZIPlib 0.13.69 allows attackers to overwrite arbitrary files via a .. (dot dot) in a zip file, because of the function unzzip_cat in the bins/unzzipcat-mem.c file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
zziplib (PTS)jessie (security), jessie0.13.62-3+deb8u1vulnerable
buster, sid, stretch0.13.62-3.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
zziplibsource(unstable)(unfixed)unimportant

Notes

https://github.com/gdraheim/zziplib/issues/62
unzzipcat-mem not installed into the binary packages

Search for package or bug name: Reporting problems