CVE-2018-17847

NameCVE-2018-17847
DescriptionThe html package (aka x/net/html) through 2018-09-25 in Go mishandles <svg><template><desc><t><svg></template>, leading to a "panic: runtime error" (index out of range) in (*nodeStack).pop in node.go, called from (*parser).clearActiveFormattingElements, during an html.Parse call.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs911795

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
golang-go.net-dev (PTS)jessie0.0~hg20131201-1vulnerable
golang-golang-x-net-dev (PTS)stretch1:0.0+git20161013.8b4af36+dfsg-3fixed
buster1:0.0+git20181201.351d144+dfsg-2vulnerable
sid1:0.0+git20181201.351d144+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
golang-go.net-devsource(unstable)(unfixed)medium
golang-golang-x-net-devsource(unstable)1:0.0+git20181201.351d144+dfsg-3medium911795
golang-golang-x-net-devsourcestretch(not affected)

Notes

[stretch] - golang-golang-x-net-dev <not-affected> (Vulnerable code not present)
[jessie] - golang-go.net-dev <ignored> (Minor issue)
https://github.com/golang/go/issues/27846
https://github.com/golang/net/commit/4b62a64f59f73840b9ab79204c94fee61cd1ba2c

Search for package or bug name: Reporting problems