CVE-2018-17848

NameCVE-2018-17848
DescriptionThe html package (aka x/net/html) through 2018-09-25 in Go mishandles <math><template><mn><b></template>, leading to a "panic: runtime error" (index out of range) in (*insertionModeStack).pop in node.go, called from inHeadIM, during an html.Parse call.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs911795

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
golang-go.net-dev (PTS)jessie0.0~hg20131201-1vulnerable
golang-golang-x-net-dev (PTS)stretch1:0.0+git20161013.8b4af36+dfsg-3vulnerable
buster, sid1:0.0+git20180124.0ed95ab+dfsg-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
golang-go.net-devsource(unstable)(unfixed)
golang-golang-x-net-devsource(unstable)(unfixed)911795

Notes

[jessie] - golang-go.net-dev <ignored> (Minor issue)
https://github.com/golang/go/issues/27846
check, possibly introduced in later versions

Search for package or bug name: Reporting problems