CVE-2018-17953

NameCVE-2018-17953
DescriptionA incorrect variable in a SUSE specific patch for pam_access rule matching in PAM 1.3.0 in openSUSE Leap 15.0 and SUSE Linux Enterprise 15 could lead to pam_access rules not being applied (fail open).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pam (PTS)jessie1.1.8-3.1+deb8u2fixed
stretch1.1.8-3.6fixed
bullseye, sid, buster1.3.1-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pamsource(unstable)(not affected)

Notes

- pam <not-affected> (Issue introduced by SUSE specific patch)
https://bugzilla.suse.com/show_bug.cgi?id=1115640
Issue introduced by SUSE specific patch (pam-hostnames-in-access_conf.patch)
https://build.opensuse.org/package/view_file/Linux-PAM/pam/pam-hostnames-in-access_conf.patch
And fixed with (use-correct-IP-address.patch)
https://build.opensuse.org/package/view_file/Linux-PAM/pam/use-correct-IP-address.patch

Search for package or bug name: Reporting problems