CVE-2018-17960

NameCVE-2018-17960
DescriptionCKEditor 4.x before 4.11.0 allows user-assisted XSS involving a source-mode paste.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ckeditor (PTS)stretch4.5.7+dfsg-2vulnerable
stretch (security)4.5.7+dfsg-2+deb9u1vulnerable
buster4.11.1+dfsg-1fixed
bullseye4.16.0+dfsg-2fixed
bookworm, sid4.16.2+dfsg-1fixed
ckeditor3 (PTS)stretch3.6.6.1+dfsg-1vulnerable
buster3.6.6.1+dfsg-3vulnerable
bookworm, sid, bullseye3.6.6.1+dfsg-7vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ckeditorsource(unstable)4.11.1+dfsg-1low
ckeditor3sourcestretch(unfixed)end-of-life
ckeditor3source(unstable)(unfixed)low
fckeditorsource(unstable)(unfixed)

Notes

[stretch] - ckeditor <ignored> (Minor issue, XSS through direct copy/paste by victim, no identified patch)
[jessie] - ckeditor <ignored> (Minor issue)
[stretch] - ckeditor3 <end-of-life> (EOL'd for stretch)

Search for package or bug name: Reporting problems