CVE-2018-17983

NameCVE-2018-17983
Descriptioncext/manifest.c in Mercurial before 4.7.2 has an out-of-bounds read during parsing of a malformed manifest entry.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mercurial (PTS)stretch4.0-1+deb9u1vulnerable
stretch (security)4.0-1+deb9u2vulnerable
buster4.8.2-1+deb10u1fixed
bullseye5.4.1-1fixed
sid5.4.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mercurialsourcejessie(not affected)
mercurialsource(unstable)4.7.2-1unimportant

Notes

[jessie] - mercurial <not-affected> (Vulnerable code not present)
https://www.mercurial-scm.org/repo/hg/rev/5405cb1a7901
Crash in CLI tool, no security impact

Search for package or bug name: Reporting problems