CVE-2018-18284

NameCVE-2018-18284
DescriptionArtifex Ghostscript 9.25 and earlier allows attackers to bypass a sandbox protection mechanism via vectors involving the 1Policy operator.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1552-1, DSA-4336-1
NVD severityhigh (attack range: remote)
Debian Bugs911175

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ghostscript (PTS)jessie9.06~dfsg-2+deb8u7vulnerable
jessie (security)9.06~dfsg-2+deb8u12fixed
stretch9.20~dfsg-3.2+deb9u5vulnerable
stretch (security)9.26~dfsg-0+deb9u1fixed
buster, sid9.26~dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ghostscriptsource(unstable)9.25~dfsg-3high911175
ghostscriptsourcejessie9.06~dfsg-2+deb8u11highDLA-1552-1
ghostscriptsourcestretch9.25~dfsg-0+deb9u1highDSA-4336-1

Notes

https://bugs.ghostscript.com/show_bug.cgi?id=699963
https://bugs.chromium.org/p/project-zero/issues/detail?id=1696
https://www.openwall.com/lists/oss-security/2018/10/16/2
http://git.ghostscript.com/?p=ghostpdl.git;h=8d19fdf63f91f50466b08f23e2d93d37a4c5ea0b

Search for package or bug name: Reporting problems