CVE-2018-18438

NameCVE-2018-18438
DescriptionQemu has integer overflows because IOReadHandler and its associated functions use a signed integer data type for a size value.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs911470

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)jessie1:2.1+dfsg-12+deb8u6vulnerable
jessie (security)1:2.1+dfsg-12+deb8u7vulnerable
stretch1:2.8+dfsg-6+deb9u4vulnerable
stretch (security)1:2.8+dfsg-6+deb9u5vulnerable
buster, sid1:2.12+dfsg-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusource(unstable)(unfixed)911470
qemu-kvmsource(unstable)(unfixed)

Notes

[stretch] - qemu <ignored> (Minor issue, too intrusive to backport)
[jessie] - qemu <ignored> (Minor issue, too intrusive to backport)
https://lists.gnu.org/archive/html/qemu-devel/2018-10/msg02396.html
https://lists.gnu.org/archive/html/qemu-devel/2018-10/msg02402.html
https://www.openwall.com/lists/oss-security/2018/10/17/3

Search for package or bug name: Reporting problems