CVE-2018-18508

NameCVE-2018-18508
DescriptionIn Network Security Services (NSS) before 3.36.7 and before 3.41.1, a malformed signature can cause a crash due to a null dereference, resulting in a Denial of Service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1704-1, DLA-2388-1
NVD severitymedium
Debian Bugs921614

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nss (PTS)stretch2:3.26.2-1.1+deb9u1vulnerable
stretch (security)2:3.26.2-1.1+deb9u2fixed
buster, buster (security)2:3.42.1-1+deb10u3fixed
bullseye, sid2:3.59-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nsssourcejessie2:3.26-1+debu8u4DLA-1704-1
nsssourcestretch2:3.26.2-1.1+deb9u2DLA-2388-1
nsssource(unstable)2:3.42.1-1921614

Notes

https://hg.mozilla.org/projects/nss/rev/08d1b0c1117f
https://hg.mozilla.org/projects/nss/rev/5e70b72131ac
https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS/NSS_3.42.1_release_notes

Search for package or bug name: Reporting problems