CVE-2018-18544

NameCVE-2018-18544
DescriptionThere is a memory leak in the function WriteMSLImage of coders/msl.c in ImageMagick 7.0.8-13 Q16, and the function ProcessMSLScript of coders/msl.c in GraphicsMagick before 1.3.31.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
graphicsmagick (PTS)jessie1.3.20-3+deb8u2vulnerable
jessie (security)1.3.20-3+deb8u4vulnerable
stretch (security), stretch1.3.30+hg15796-1~deb9u2vulnerable
buster, sid1.3.31-1fixed
imagemagick (PTS)jessie8:6.8.9.9-5+deb8u12vulnerable
jessie (security)8:6.8.9.9-5+deb8u15vulnerable
stretch (security), stretch8:6.9.7.4+dfsg-11+deb9u6vulnerable
buster, sid8:6.9.10.14+dfsg-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
graphicsmagicksource(unstable)1.3.31-1unimportant
imagemagicksource(unstable)8:6.9.10.14+dfsg-1unimportant

Notes

https://github.com/ImageMagick/ImageMagick/issues/1360

Search for package or bug name: Reporting problems