CVE-2018-18584

NameCVE-2018-18584
DescriptionIn mspack/cab.h in libmspack before 0.8alpha and cabextract before 1.8, the CAB block input buffer is one byte too small for the maximal Quantum block, leading to an out-of-bounds write.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1555-1
NVD severitymedium
Debian Bugs911640

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cabextract (PTS)jessie1.4-5fixed
stretch1.6-1fixed
buster1.9-1fixed
bullseye, sid1.9-2fixed
libmspack (PTS)jessie0.5-1+deb8u1vulnerable
jessie (security)0.5-1+deb8u4fixed
stretch0.5-1+deb9u3fixed
stretch (security)0.5-1+deb9u2vulnerable
bullseye, sid, buster0.10.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cabextractsource(unstable)1.4-5
libmspacksource(unstable)0.8-1911640
libmspacksourcejessie0.5-1+deb8u3DLA-1555-1
libmspacksourcestretch0.5-1+deb9u3

Notes

Starting with 1.4-5 cabextract uses the mspack system library
https://github.com/kyz/libmspack/commit/40ef1b4093d77ad3a5cfcee1f5cb6108b3a3bcc2
https://www.openwall.com/lists/oss-security/2018/10/22/1

Search for package or bug name: Reporting problems