CVE-2018-18849

NameCVE-2018-18849
DescriptionIn Qemu 3.0.0, lsi_do_msgin in hw/scsi/lsi53c895a.c allows out-of-bounds access by triggering an invalid msg_len value.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1781-1, DSA-4454-1
NVD severitylow (attack range: local)
Debian Bugs912535

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)jessie1:2.1+dfsg-12+deb8u6vulnerable
jessie (security)1:2.1+dfsg-12+deb8u11fixed
stretch1:2.8+dfsg-6+deb9u5vulnerable
stretch (security)1:2.8+dfsg-6+deb9u7fixed
buster1:3.1+dfsg-8~deb10u1fixed
sid1:3.1+dfsg-8fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusource(unstable)1:3.1+dfsg-1low912535
qemusourcejessie1:2.1+dfsg-12+deb8u11lowDLA-1781-1
qemusourcestretch1:2.8+dfsg-6+deb9u6lowDSA-4454-1
qemu-kvmsource(unstable)(unfixed)low

Notes

https://git.qemu.org/?p=qemu.git;a=commit;h=e58ccf039650065a9442de43c9816f81e88f27f6
https://www.openwall.com/lists/oss-security/2018/11/01/1

Search for package or bug name: Reporting problems