CVE-2018-18954

NameCVE-2018-18954
DescriptionThe pnv_lpc_do_eccb function in hw/ppc/pnv_lpc.c in Qemu before 3.1 allows out-of-bounds write or read access to PowerNV memory.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4454-1
NVD severitylow
Debian Bugs914604

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)stretch1:2.8+dfsg-6+deb9u9fixed
stretch (security)1:2.8+dfsg-6+deb9u14fixed
buster, buster (security)1:3.1+dfsg-8+deb10u8fixed
bullseye1:5.2+dfsg-9fixed
sid1:5.2+dfsg-10fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusourcejessie(not affected)
qemusourcestretch1:2.8+dfsg-6+deb9u6DSA-4454-1
qemusource(unstable)1:3.1+dfsg-1low914604
qemu-kvmsource(unstable)(unfixed)

Notes

[jessie] - qemu <not-affected> (Vulnerable code not present. ppc/pnv lpc was added in 2.7)
https://git.qemu.org/?p=qemu.git;a=commit;h=d07945e78eb6b593cd17a4640c1fc9eb35e3245d

Search for package or bug name: Reporting problems