CVE-2018-19131

NameCVE-2018-19131
DescriptionSquid before 4.4 has XSS via a crafted X.509 certificate during HTTP(S) error page generation for certificate errors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs912293

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
squid (PTS)buster, sid4.4-1fixed
squid3 (PTS)jessie3.4.8-6+deb8u5vulnerable
jessie (security)3.4.8-6+deb8u6vulnerable
stretch (security), stretch3.5.23-5+deb9u1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
squidsource(unstable)4.4-1unimportant912293
squid3source(unstable)(unfixed)unimportant

Notes

http://www.squid-cache.org/Advisories/SQUID-2018_4.txt
Squid in Debian builds without TLS support

Search for package or bug name: Reporting problems