CVE-2018-19132

NameCVE-2018-19132
DescriptionSquid before 4.4, when SNMP is enabled, allows a denial of service (Memory Leak) via an SNMP packet.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs912294

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
squid (PTS)buster, sid4.4-1fixed
squid3 (PTS)jessie (security), jessie3.4.8-6+deb8u5vulnerable
stretch (security), stretch3.5.23-5+deb9u1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
squidsource(unstable)4.4-1low912294
squid3source(unstable)(unfixed)low

Notes

[stretch] - squid3 <postponed> (Can be fixed along in a future DSA)
http://www.squid-cache.org/Advisories/SQUID-2018_5.txt

Search for package or bug name: Reporting problems