CVE-2018-19134

NameCVE-2018-19134
DescriptionIn Artifex Ghostscript through 9.25, the setpattern operator did not properly validate certain types. A specially crafted PostScript document could exploit this to crash Ghostscript or, possibly, execute arbitrary code in the context of the Ghostscript process. This is a type confusion issue because of failure to check whether the Implementation of a pattern dictionary was a structure type.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1620-1, DSA-4346-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ghostscript (PTS)jessie9.06~dfsg-2+deb8u7vulnerable
jessie (security)9.26a~dfsg-0+deb8u1fixed
stretch9.26a~dfsg-0+deb9u1fixed
stretch (security)9.26a~dfsg-0+deb9u2fixed
buster, sid9.27~dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ghostscriptsource(unstable)9.26~dfsg-1medium
ghostscriptsourcejessie9.06~dfsg-2+deb8u13mediumDLA-1620-1
ghostscriptsourcestretch9.26~dfsg-0+deb9u1mediumDSA-4346-1

Notes

https://bugs.ghostscript.com/show_bug.cgi?id=700141
http://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=693baf02152119af6e6afd30bb8ec76d14f84bbf (master)
http://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=7c8f85a23db24031945af3cacb2c0b4740e67072 (ghostscript-9.26)

Search for package or bug name: Reporting problems