CVE-2018-19141

NameCVE-2018-19141
DescriptionOpen Ticket Request System (OTRS) 4.0.x before 4.0.33 and 5.0.x before 5.0.31 allows an admin to conduct an XSS attack via a modified URL because user and customer preferences are mishandled.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1592-1
NVD severitylow (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
otrs2 (PTS)stretch/non-free (security), stretch/non-free5.0.16-1+deb9u6vulnerable
buster/non-free, sid/non-free6.0.14-1fixed
jessie3.3.18-1+deb8u4vulnerable
jessie (security)3.3.18-1+deb8u7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
otrs2source(unstable)6.0.1-1low
otrs2sourcejessie3.3.18-1+deb8u7lowDLA-1592-1

Notes

https://community.otrs.com/security-advisory-2018-09-security-update-for-otrs-framework/
Only the 4.x and 5.x series are affected (and possibly earlier versions).
Add workaround and mark first 6.x version as fixing version

Search for package or bug name: Reporting problems