CVE-2018-19210

NameCVE-2018-19210
DescriptionIn LibTIFF 4.0.9, there is a NULL pointer dereference in the TIFFWriteDirectorySec function in tif_dirwrite.c that will lead to a denial of service attack, as demonstrated by tiffset.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs913675

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tiff (PTS)jessie4.0.3-12.3+deb8u5vulnerable
jessie (security)4.0.3-12.3+deb8u7vulnerable
stretch4.0.8-2+deb9u2vulnerable
stretch (security)4.0.8-2+deb9u4vulnerable
buster, sid4.0.10-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tiffsource(unstable)(unfixed)medium913675
tiff3source(unstable)(unfixed)medium

Notes

[stretch] - tiff <postponed> (Minor issue, revisit when fixed upstream)
http://bugzilla.maptools.org/show_bug.cgi?id=2820

Search for package or bug name: Reporting problems