CVE-2018-19295

NameCVE-2018-19295
DescriptionSylabs Singularity 2.4 to 2.6 allows local users to conduct Improper Input Validation attacks.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
singularity-container (PTS)buster, sid3.0.3+ds-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
singularity-containersource(unstable)2.6.1-1high

Notes

https://www.openwall.com/lists/oss-security/2018/12/12/2
https://bugzilla.novell.com/show_bug.cgi?id=1111411

Search for package or bug name: Reporting problems