CVE-2018-19409

NameCVE-2018-19409
DescriptionAn issue was discovered in Artifex Ghostscript before 9.26. LockSafetyParams is not checked correctly if another device is used.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-1598-1, DSA-4346-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ghostscript (PTS)buster9.27~dfsg-2+deb10u5fixed
buster (security)9.27~dfsg-2+deb10u9fixed
bullseye9.53.3~dfsg-7+deb11u6fixed
bullseye (security)9.53.3~dfsg-7+deb11u7fixed
bookworm10.0.0~dfsg-11+deb12u3fixed
bookworm (security)10.0.0~dfsg-11+deb12u4fixed
sid, trixie10.03.1~dfsg~git20240518-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ghostscriptsourcejessie9.06~dfsg-2+deb8u12DLA-1598-1
ghostscriptsourcestretch9.26~dfsg-0+deb9u1DSA-4346-1
ghostscriptsource(unstable)9.26~dfsg-1

Notes

https://bugs.ghostscript.com/show_bug.cgi?id=700176
https://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=661e8d8fb8248c38d67958beda32f3a5876d0c3f
https://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=ea1b3ef437f39e45874f821c06bd953196625ac5

Search for package or bug name: Reporting problems