CVE-2018-19476

NameCVE-2018-19476
Descriptionpsi/zicc.c in Artifex Ghostscript before 9.26 allows remote attackers to bypass intended access restrictions because of a setcolorspace type confusion.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1598-1, DSA-4346-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ghostscript (PTS)jessie9.06~dfsg-2+deb8u7vulnerable
jessie (security)9.06~dfsg-2+deb8u12fixed
stretch9.20~dfsg-3.2+deb9u5vulnerable
stretch (security)9.26~dfsg-0+deb9u1fixed
buster, sid9.26~dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ghostscriptsource(unstable)9.26~dfsg-1
ghostscriptsourcejessie9.06~dfsg-2+deb8u12DLA-1598-1
ghostscriptsourcestretch9.26~dfsg-0+deb9u1DSA-4346-1

Notes

http://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=67d760ab775dae4efe803b5944b0439aa3c0b04a (ghostscript-9.26)
http://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=434753adbe8be5534bfb9b7d91746023e8073d16 (master)
https://bugs.ghostscript.com/show_bug.cgi?id=700169

Search for package or bug name: Reporting problems