CVE-2018-19477

NameCVE-2018-19477
Descriptionpsi/zfjbig2.c in Artifex Ghostscript before 9.26 allows remote attackers to bypass intended access restrictions because of a JBIG2Decode type confusion.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1598-1, DSA-4346-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ghostscript (PTS)jessie9.06~dfsg-2+deb8u7vulnerable
jessie (security)9.06~dfsg-2+deb8u12fixed
stretch9.20~dfsg-3.2+deb9u5vulnerable
stretch (security)9.26~dfsg-0+deb9u1fixed
buster, sid9.26~dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ghostscriptsource(unstable)9.26~dfsg-1
ghostscriptsourcejessie9.06~dfsg-2+deb8u12DLA-1598-1
ghostscriptsourcestretch9.26~dfsg-0+deb9u1DSA-4346-1

Notes

http://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=ef252e7dc214bcbd9a2539216aab9202848602bb (ghostscript-9.26)
http://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=606a22e77e7f081781e99e44644cd0119f559e03 (master)
https://bugs.ghostscript.com/show_bug.cgi?id=700168

Search for package or bug name: Reporting problems