CVE-2018-19516

NameCVE-2018-19516
Descriptionmessagepartthemes/default/defaultrenderer.cpp in messagelib in KDE Applications before 18.12.0 does not properly restrict the handling of an http-equiv="REFRESH" value.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs915039

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
kf5-messagelib (PTS)stretch4:16.04.3-3~deb9u1vulnerable
buster4:18.08.3-2fixed
bullseye, sid4:20.04.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kf5-messagelibsource(unstable)4:18.08.3-2915039

Notes

[stretch] - kf5-messagelib <no-dsa> (Minor issue)
https://www.kde.org/info/security/advisory-20181128-1.txt
https://cgit.kde.org/messagelib.git/commit/?id=34765909cdf8e55402a8567b48fb288839c61612

Search for package or bug name: Reporting problems