CVE-2018-19608

NameCVE-2018-19608
DescriptionArm Mbed TLS before 2.14.1, before 2.7.8, and before 2.1.17 allows a local unprivileged attacker to recover the plaintext of RSA decryption, which is used in RSA-without-(EC)DH(E) cipher suites.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs915796

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mbedtls (PTS)stretch (security), stretch2.4.2-1+deb9u3vulnerable
buster2.13.0-3vulnerable
sid2.14.1-2fixed
polarssl (PTS)jessie1.3.9-2.1+deb8u3vulnerable
jessie (security)1.3.9-2.1+deb8u4vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mbedtlssource(unstable)2.14.1-1915796
polarsslsource(unstable)(unfixed)

Notes

http://cat.eyalro.net/
https://tls.mbed.org/tech-updates/releases/mbedtls-2.14.1-2.7.8-and-2.1.17-released
https://tls.mbed.org/tech-updates/security-advisories/mbedtls-security-advisory-2018-03

Search for package or bug name: Reporting problems