CVE-2018-19756

NameCVE-2018-19756
DescriptionThere is a heap-based buffer over-read at stb_image.h (function: stbi__tga_load) in libsixel 1.8.2 that will cause a denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs931311

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libsixel (PTS)jessie1.1.2-1fixed
stretch1.5.2-2+deb9u1fixed
buster1.8.2-1+deb10u1fixed
bullseye, sid1.8.6-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libsixelsource(unstable)1.8.2-2931311
libsixelsourcebuster1.8.2-1+deb10u1
libsixelsourcejessie(not affected)
libsixelsourcestretch1.5.2-2+deb9u1

Notes

[jessie] - libsixel <not-affected> (The vulnerable code is not present)
https://github.com/saitoha/libsixel/issues/80
https://bugzilla.redhat.com/show_bug.cgi?id=1649198 (reproducer)
CVE description is misleading, not an issue in libstb

Search for package or bug name: Reporting problems