CVE-2018-19758

NameCVE-2018-19758
DescriptionThere is a heap-based buffer over-read at wav.c in wav_write_header in libsndfile 1.0.28 that will cause a denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1632-1
NVD severitymedium (attack range: remote)
Debian Bugs917416

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libsndfile (PTS)jessie1.0.25-9.1+deb8u1vulnerable
jessie (security)1.0.25-9.1+deb8u4fixed
stretch1.0.27-3vulnerable
bullseye, sid, buster1.0.28-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libsndfilesource(unstable)1.0.28-5medium917416
libsndfilesourcejessie1.0.25-9.1+deb8u3mediumDLA-1632-1

Notes

[stretch] - libsndfile <no-dsa> (Minor issue)
https://bugzilla.redhat.com/show_bug.cgi?id=1643812
https://github.com/erikd/libsndfile/issues/435
https://github.com/erikd/libsndfile/commit/42132c543358cee9f7c3e9e9b15bb6c1063a608e
when fixing this issue, the fix needs to be made complete to not open CVE-2019-3832

Search for package or bug name: Reporting problems