CVE-2018-19787

NameCVE-2018-19787
DescriptionAn issue was discovered in lxml before 4.2.5. lxml/html/clean.py in the lxml.html.clean module does not remove javascript: URLs that use escaping, allowing a remote attacker to conduct XSS attacks, as demonstrated by "j a v a s c r i p t:" in Internet Explorer. This is a similar issue to CVE-2014-3146.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1604-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lxml (PTS)jessie3.4.0-1vulnerable
jessie (security)3.4.0-1+deb8u1fixed
stretch3.7.1-1vulnerable
buster, sid4.2.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lxmlsource(unstable)4.2.5-1
lxmlsourcejessie3.4.0-1+deb8u1DLA-1604-1

Notes

[stretch] - lxml <no-dsa> (Minor issue)
Fixed by: https://github.com/lxml/lxml/commit/6be1d081b49c97cfd7b3fbd934a193b668629109 (lxml-4.2.5)

Search for package or bug name: Reporting problems