CVE-2018-19800

NameCVE-2018-19800
Descriptionaubio v0.4.0 to v0.4.8 has a Buffer Overflow in new_aubio_tempo.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs930186

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
aubio (PTS)jessie0.4.1-2vulnerable
stretch0.4.3-4vulnerable
buster0.4.6-2vulnerable
bullseye, sid0.4.9-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
aubiosource(unstable)0.4.9-1high930186

Notes

[buster] - aubio <no-dsa> (Minor issue)
[stretch] - aubio <no-dsa> (Minor issue)
[jessie] - aubio <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems