CVE-2018-19837

NameCVE-2018-19837
DescriptionIn LibSass prior to 3.5.5, Sass::Eval::operator()(Sass::Binary_Expression*) inside eval.cpp allows attackers to cause a denial-of-service resulting from stack consumption via a crafted sass file, because of certain incorrect parsing of '%' as a modulo operator in parser.cpp.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libsass (PTS)stretch3.4.3-1vulnerable
buster, sid3.5.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libsasssource(unstable)3.5.4+20180621~c0a6cf3-1

Notes

[stretch] - libsass <no-dsa> (Minor issue)
https://github.com/sass/libsass/commit/210fdff7a65370c2ae24e022a2b35da8c423cc5f
https://github.com/sass/libsass/issues/2659

Search for package or bug name: Reporting problems