CVE-2018-19841

NameCVE-2018-19841
DescriptionThe function WavpackVerifySingleBlock in open_utils.c in libwavpack.a in WavPack through 5.1.0 allows attackers to cause a denial-of-service (out-of-bounds read and application crash) via a crafted WavPack Lossless Audio file, as demonstrated by wvunpack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs915565

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wavpack (PTS)jessie4.70.0-1vulnerable
stretch (security), stretch5.0.0-2+deb9u2vulnerable
buster, sid5.1.0-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wavpacksource(unstable)5.1.0-5915565

Notes

[stretch] - wavpack <no-dsa> (Minor issue)
[jessie] - wavpack <no-dsa> (Minor issue)
https://github.com/dbry/WavPack/commit/bba5389dc598a92bdf2b297c3ea34620b6679b5b
https://github.com/dbry/WavPack/issues/54

Search for package or bug name: Reporting problems