CVE-2018-19870

NameCVE-2018-19870
DescriptionAn issue was discovered in Qt before 5.11.3. A malformed GIF image causes a NULL pointer dereference in QGifHandler resulting in a segmentation fault.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1627-1, DSA-4374-1
NVD severitymedium (attack range: remote)
Debian Bugs923003

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qt4-x11 (PTS)jessie4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1vulnerable
stretch4:4.8.7+dfsg-11vulnerable
buster, sid4:4.8.7+dfsg-18fixed
qtbase-opensource-src (PTS)jessie5.3.2+dfsg-4+deb8u2vulnerable
jessie (security)5.3.2+dfsg-4+deb8u3fixed
stretch5.7.1+dfsg-3vulnerable
stretch (security)5.7.1+dfsg-3+deb9u1fixed
buster, sid5.11.3+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qt4-x11source(unstable)4:4.8.7+dfsg-18low923003
qtbase-opensource-srcsource(unstable)5.11.3+dfsg-2low
qtbase-opensource-srcsourceexperimental5.11.3+dfsg-1medium
qtbase-opensource-srcsourcejessie5.3.2+dfsg-4+deb8u3mediumDLA-1627-1
qtbase-opensource-srcsourcestretch5.7.1+dfsg-3+deb9u1mediumDSA-4374-1

Notes

[stretch] - qt4-x11 <no-dsa> (Minor issue)
[jessie] - qt4-x11 <ignored> (Minor issue)
https://blog.qt.io/blog/2018/12/04/qt-5-11-3-released-important-security-updates/
https://codereview.qt-project.org/#/c/235998/
affected code can be in src/gui/image/qgifhandler.cpp or in
src/plugins/imageformats/gif/qgifhandler.cpp depending on the version
https://github.com/qt/qtbase/commit/2841e2b61e32f26900bde987d469c8b97ea31999

Search for package or bug name: Reporting problems